Linux: "error while loading shared libraries"

Fade In Knowledge Base
2018-05-17 10:10

If, when running Fade In from the command line on Linux, the application fails to start and you receive an error like:

fadein: error while loading shared libraries: <libraryname>.so.1: cannot open shared object file: No such file or directory

that is an indication that you may have installed the 32-bit version of Fade In on a 64-bit version of Linux, or vice versa.

Please double-check that you've downloaded the correct version of Fade In for your architecture.

. . .

You might also check if your repository has updated to a more recent version of a particular library. If so, you may be able to download the required version of the library in question and install it alongside the current newer version. 

. . .

One more thing you can try is compiling the missing library from source. For this, you'll need to download the source code (generally as a .tar.gz archive, and preferably from the official project site). Then, unarchive it into its own folder.

The steps for compiling and installing are the similar between libraries. Usually a file called INSTALL or something similar will give specific instructions, but generally speaking it involves basically typing:

./configure
make
sudo make install

 inside the directory where you unarchived the source tarball.

 

Tags: linux
Average rating: 0 (0 Votes)

You cannot comment on this entry